読者です 読者をやめる 読者になる 読者になる

Milkode0.2.4を緊急リリース - RubyGems1.3でインストール出来ない問題を修正しました。

Milkode0.2.3をインストール出来ないという報告が何点かあり調査をしていました。原因が分かったため、修正したMilkode0.2.4をリリースします。

0.2.2以前ではインストールが上手くいっていたのに0.2.3で失敗した方は、0.2.4ならインストール出来るはずです。
インストール方法

原因

Milkode0.2.3はRuby1.9.2(RubyGems1.8.6)でgemを作っていたからでした。Milkode0.2.2以前と同じ様にRuby1.8.6(RubyGems1.3.6)で作成したら直りました。
※ ちょっと前に話題になってたRubyGems後方互換性問題ってこのあたりのことなのかなー。

トラブルが起きてしまった方ご迷惑をおかけました。何人かの皆さんがGithunのIssue(1,2)やブログ,Twitterに問題を書いてくれており、おかげさまで原因を突き止めることが出来ました。

今後はこのようなことがないよう気をつけます。